Announcement

Collapse
No announcement yet.

P-20 Blade Holder Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • snkysnake
    replied
    Thanks Rick

    Hi Rick, I just watched your video...again. Your video is one of the reasons I went with the Delta, ease of blade changes. I have been doing the changes just like in your video, but of course I only have to adjust the knob if I change blade sizes. The problem that developed yesterday is that when I get done adjusting, the clamp springs back open all by itself. after a week of many sucsessful blade changes, I suddenly can't get it to work. If I tighten the knob just a little too much, the lever won't close..if I back off just a hair...the clamp springs open on it's own. Not sure what to do now except wait for the new clamps. BTW I looked over the clamps real good, even removed the screw, nothing looks bent or broke or worn. Anyway, thanks for making the videos, they are really helpful !... Larry

    Leave a comment:


  • snkysnake
    replied
    delta clamps

    Well guys, I appreciate all the replies. I talked to Delta this morning, and the little bitty bolts are on back order till at least the 23 rd .BUT , they are sending me two new clamps gratis ! I follow what you are saying, about very small adjustments, and I thought I had the hang of it.The adjustment knobs on my clamps have the sort of splined look to them, like points on a compass around the edge... so to give you an example, I am moving that knob like one or two tics of the compass. Not sure why it went in the toilet yesterday, I've done probably 40 or so top feeding cuts this week, and not a problem one with the holder. Once I got it adjusted for the blade size I never had to touch the knob again. But yesterday the blade holder would not work for anything. I will tinker some more today, and see if I can get it going so I don't have to wait for the new holders.. I'll keep you posted. Thanks again for the help....Larry

    Leave a comment:


  • Rick-H
    replied
    I have a free video of how to properly use the Delta clamp on my web site. It is in with the other 60 free videos about scrolling.
    http://www.scrollsaws.com

    Leave a comment:


  • Mick Walker
    replied
    snkysnake, I have had my P-20 for over 3 years and no clamp problems, if the bolt in the clamp is bent your are tightening it too much before closing the clamp. You don't need a lot of pressure on the clamp to hold the blade in place. The way I d o it is to adjust the nut on the side just enough so the blade will slip out when I close the clamp and apply the tension. Release the tension and the clamp then turn the adjustment just a tiny bit. The more you use your saw this will just come naturally, you will know just how much to turn the adjustment nut. I learned the hard way, I broke the bolt on a clamp because I was tightening it too much on my old saw. Hope this helps.

    Leave a comment:


  • Greenfield_Bob
    replied
    Larry, I had the same problem with mine, both of them.
    I called Delta and they sent me 2 new ones, no trouble since.
    Given them a call.

    Bob

    Leave a comment:


  • Green Frog
    replied
    bolt ?

    if you take the bolt out you can see a slight bow in it or at least i did

    Leave a comment:


  • snkysnake
    replied
    So the littlest part is the culprit?

    So was this bolt visibly bent ? Did you notice an immediate fix when you replaced the bolt ? Maybe if that's the problem , then that means I have been too heavy handed with the holders? I will call Delta this morning, I hate not being able to load a blade and cut something ! Arrrrg ! Thanks for the help....Larry

    Leave a comment:


  • Green Frog
    replied
    P-20

    Had same problem here in my case the little bolt that goes though the holder and the nut that is acorn. nthe bolt gets bent so turn it 1/4 turn and order some extra bolts it is 3.5 mm and only delta carries it I also have extra blade holders on hand

    Leave a comment:


  • snkysnake
    started a topic P-20 Blade Holder Problem

    P-20 Blade Holder Problem

    I have been using my new P-20 for a week or so , top and bottom feeding, changing blades etc. No problems up until today. Now I cannot get the blade holders to function right. The lever dosen't seem to want to seat and STAY ! With just the slightest adjustment, it is either too tight to flip all the way forward, or , with a slight adjustment in the other direction , it will close, but will pop open as soon as I flip the tension lever up. Any idea what I'm doing wrong ?? I thought I took to the Delta clamps like a duck to water, and can't figure out what I'm doing different today. Any help or suggestions would be appreciated... Larry

Unconfigured Ad Widget

Collapse

Latest Topics

Collapse

Working...
X