Announcement

Collapse
No announcement yet.

Slipping and breaking blades

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Now we've just got to get you some good wood!!!

    Bob
    www.GrobetUSA.com

    Comment


    • #32
      Originally posted by BobD
      Now we've just got to get you some good wood!!!

      Bob
      Thanks, but I've already taken care of that. I visited my local exotic hardwood supplier on Monday and got a great selection of wood, but no saw...boo hoo! I got cocobola, wenge, zebrawood, purpleheart, teak, quilted maple, maple, ash, walnut, mahogany and paduak. I won't tell you what I paid for all that because you'll all move out here , but it took me and my two kids to help bring it all in. I'm just trying to find some nice patterns now that are appropriate for the variety I have now. Yippee!
      Mia

      We are the music makers.
      We are the dreamers of dreams.


      Easy scrollin' with a DW788

      Comment


      • #33
        I forgot to mention it's all 1/4"
        Mia

        We are the music makers.
        We are the dreamers of dreams.


        Easy scrollin' with a DW788

        Comment


        • #34
          Mia,

          Where in NJ did you get the wood? I live on the other side of the river (Hudson) and could sneak in to get some wood.
          Rolf
          RBI G4 26 Hawk, EX 16 with Pegas clamps, Nova 1624 DVR XP
          Philosophy "I don't know that I can't, therefore I can"
          Proud Member of the Long Island Woodworkers Club
          And the Long Island Scrollsaw Association

          Comment


          • #35
            I am using a Delta SS350 saw, and at times I have the problem of the blade slipping
            in the upper quick clamp.
            I may not have the answer that you want, but some things to look for could be.

            - When putting the blade in the upper or lower clamp you must have at least two
            thread of the blade clamped for the blade to hold tight.

            - If the blade is not in the front most part of the holder I have found the it will slip
            when tensioning the blade or will slip shortly after starting the cut ( this is talking
            about the upper clamp )

            - If the blade is dull and the wood is closing down on the blade this could cause the blade
            to brake on the up stroke if the clamp should slip..

            - Is the blade in upside down (please do not mind me asking this because I have put them in wrong. )

            - Check the free movement of the upper and lower quick clamp it could be that they may be hanging
            up and causing the blade to break.
            jim from ontario

            Comment


            • #36
              You know, New Jersey is just a day trip for me and hubby. What's the name of that wood store again, I didn't catch it.

              Betty
              Betty

              "Congress needs to realize it is a government of the people, by the people and for the people. Not of the people, by the people and for Congress." - Dr. Benjamin Carson, Pediatric Neurosurgeon, Johns Hopkins Hospital

              Comment

              Unconfigured Ad Widget

              Collapse

              Latest Topics

              Collapse

              • Rolf
                Reply to Frustrated
                by Rolf
                What model Craftsman! Without that information we can't look up the saw and what type of clamp it has.
                Today, 07:20 AM
              • NC Scroller
                Reply to Frustrated
                by NC Scroller
                I am guessing that your clamps have probably spread due to usage. I am not aware of any aftermarket clamps that fit your saw. Did you look at ereplacementparts.com to see if they sell clamps for your model? Sorry I could not be of more help.
                Yesterday, 11:24 AM
              • Daddy's scroller
                Reply to Frustrated
                by Daddy's scroller
                I have a craftsman saw. The blade just slips out.
                05-22-2022, 07:00 PM
              • Daddy's scroller
                Reply to Frustrated
                by Daddy's scroller
                No. I haven't tried that yet...
                05-22-2022, 06:55 PM
              • Chance13
                Reply to Frustrated
                by Chance13
                I put those on my 20" Dewalt a couple years ago. Big improvement from the one Dewalt had....
                05-22-2022, 11:08 AM
              Working...
              X