Announcement

Collapse
No announcement yet.

Sylvia

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sylvia

    I have not been on for a while. Has anybody heard or seen Sylvia from texas lately? I know she was traveling. Did she make it back home?

    Thanks
    Stan

  • #2
    Stan, Sylvia has not posted on this forum for about 2 years. You can try to contact her via her website.
    "Still Montana Mike"

    "Don't worry about old age--it doesn't last that long."
    Mike's Wood-n-Things LLC

    Comment


    • #3
      I tried to contact her twice in the last two weeks, and didn't get any response. Tried to buy or beg the "life behind bars" pattern. No dice.

      Paul
      www.flicker.com/photos/woodworks44224

      Comment

      Unconfigured Ad Widget

      Collapse

      Latest Topics

      Collapse

      • NC Scroller
        Reply to Frustrated
        by NC Scroller
        I am guessing that your clamps have probably spread due to usage. I am not aware of any aftermarket clamps that fit your saw. Did you look at ereplacementparts.com to see if they sell clamps for your model? Sorry I could not be of more help.
        Today, 11:24 AM
      • Daddy's scroller
        Reply to Frustrated
        by Daddy's scroller
        I have a craftsman saw. The blade just slips out.
        Yesterday, 07:00 PM
      • Daddy's scroller
        Reply to Frustrated
        by Daddy's scroller
        No. I haven't tried that yet...
        Yesterday, 06:55 PM
      • Chance13
        Reply to Frustrated
        by Chance13
        I put those on my 20" Dewalt a couple years ago. Big improvement from the one Dewalt had....
        Yesterday, 11:08 AM
      • Rolf
        Reply to Frustrated
        by Rolf
        We need to know what saw you are using, as they have different clamps.
        Yesterday, 07:59 AM
      Working...
      X